CVE-2016-8640

Priority
Description
A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5
and 1.8.6 that leads to read and extract of any data from any table in the
pycsw database that the database user has access to. Also on PostgreSQL (at
least) it is possible to perform updates/inserts/deletes and database
modifications to any table the database user has access to.
Notes
Package
Source: pycsw (LP Ubuntu Debian)
Upstream:released (2.0.2+dfsg-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.0.2+dfsg-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (2.0.2+dfsg-1)
Ubuntu 20.04 (Focal Fossa):not-affected (2.0.2+dfsg-1)
More Information

Updated: 2020-04-24 03:33:56 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)