CVE-2016-8614

Priority
Description
A flaw was found in Ansible before version 2.2.0. The apt_key module does
not properly verify key fingerprints, allowing remote adversary to create
an OpenPGP key which matches the short key ID and inject this key instead
of the correct key.
Notes
Package
Upstream:released (2.2.0.0-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.5.1+dfsg-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (2.6.1+dfsg-1)
Ubuntu 20.04 (Focal Fossa):not-affected (2.6.1+dfsg-1)
More Information

Updated: 2020-04-24 03:33:52 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)