CVE-2016-7980

Priority
Description
Cross-site request forgery (CSRF) vulnerability in
ecrire/exec/valider_xml.php in SPIP 3.1.2 and earlier allows remote
attackers to hijack the authentication of administrators for requests that
execute the XML validator on a local file via a crafted valider_xml
request. NOTE: this issue can be combined with CVE-2016-7998 to execute
arbitrary PHP code.
Notes
Package
Source: spip (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.1.3-1)
Ubuntu 20.04 LTS (Focal Fossa):not-affected (3.1.3-1)
Ubuntu 20.10 (Groovy Gorilla):not-affected (3.1.3-1)
Patches:
Upstream:https://core.spip.net/projects/spip/repository/revisions/23200
More Information

Updated: 2020-09-09 20:54:03 UTC (commit b67d7d8b03f173f825cd706df5bd078bca500b0e)