CVE-2016-7951

Priority
Description
Multiple integer overflows in X.org libXtst before 1.2.3 allow remote X
servers to trigger out-of-bounds memory access operations by leveraging the
lack of range checks.
Notes
 sbeattie> same commit as CVE-2016-7952
 msalatore> patch released in 2:1.2.2-1+deb8u1
Package
Upstream:released (2:1.2.2-1+deb8u1, 1.2.3-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1.2.3-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (1.2.3-1)
Ubuntu 19.04 (Disco Dingo):not-affected (1.2.3-1)
Ubuntu 19.10 (Eoan):not-affected (1.2.3-1)
Patches:
Upstream:https://cgit.freedesktop.org/xorg/lib/libXtst/commit/?id=9556ad67af3129ec4a7a4f4b54a0d59701beeae3
More Information

Updated: 2019-04-26 14:18:01 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)