CVE-2016-7945

Priority
Description
Multiple integer overflows in X.org libXi before 1.7.7 allow remote X
servers to cause a denial of service (out-of-bounds memory access or
infinite loop) via vectors involving length fields.
Notes
sbeattiesame commit for CVE-2016-7946
mdeslaurpossible regression: https://bugs.freedesktop.org/show_bug.cgi?id=98204
Package
Source: libxi (LP Ubuntu Debian)
Upstream:released (1.7.7)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2:1.7.8-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2:1.7.8-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (2:1.7.8-1)
Ubuntu 20.04 (Focal Fossa):not-affected (2:1.7.8-1)
Patches:
Upstream:https://cgit.freedesktop.org/xorg/lib/libXi/commit/?id=19a9cd607de73947fcfb104682f203ffe4e1f4e5
More Information

Updated: 2019-12-05 19:33:21 UTC (commit 0aa5e7c87c8b55d2ec5c7f4ca1179cf75de91961)