CVE-2016-7568

Priority
Description
Integer overflow in the gdImageWebpCtx function in gd_webp.c in the GD
Graphics Library (aka libgd) through 2.2.3, as used in PHP through 7.0.11,
allows remote attackers to cause a denial of service (heap-based buffer
overflow) or possibly have unspecified other impact via crafted imagewebp
and imagedestroy calls.
Assigned-to
mdeslaur
Notes
mdeslaurphp uses the system libgd2
code in gd 2.1.x is different, can use the php5 patch
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):released (2.1.0-3ubuntu0.5)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.1.1-4ubuntu0.16.04.5)
Patches:
Upstream:https://github.com/libgd/libgd/commit/40bec0f38f50e8510f5bb71a82f516d46facde03
Package
Source: php5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (uses system gd)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=46df0642618eabc5b5b7df490d1ae23bda00a745
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system gd)
Patches:
Upstream:https://github.com/php/php-src/commit/c18263e0e0769faee96a5d0ee04b750c442783c6
More Information

Updated: 2019-12-05 18:46:17 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)