CVE-2016-7429

Priority
Low
Description
NTP before 4.2.8p9 changes the peer structure to the interface it receives
the response from a source, which allows remote attackers to cause a denial
of service (prevent communication with a source) by sending a response for
a source to an interface the source does not use.
References
Bugs
Notes
 mdeslaur> ntp-4.2.7p385, up to but not including ntp-4.2.8p9, and
 mdeslaur> ntp-4.3.0 up to, but not including ntp-4.3.94
Package
Source: ntp (LP Ubuntu Debian)
Upstream:released (1:4.2.8p9+dfsg-1, ntp-4.2.8p9)
Ubuntu 17.10 (Artful Aardvark):not-affected (1:4.2.8p9+dfsg-2ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (1:4.2.6.p3+dfsg-1ubuntu3.11)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:4.2.6.p5+dfsg-3ubuntu2.14.04.11)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (1:4.2.8p4+dfsg-3ubuntu5.5)
Ubuntu 16.10 (Yakkety Yak):released (1:4.2.8p8+dfsg-1ubuntu2.1)
Ubuntu 17.04 (Zesty Zapus):not-affected (1:4.2.8p9+dfsg-2ubuntu1)
Patches:
Vendor:https://git.centos.org/blob/rpms!ntp.git/4eb1db127a6177011bd913bf4f446e8f701179d6/SOURCES!ntp-4.2.6p5-cve-2016-7429.patch
Upstream:http://bk1.ntp.org/ntp-stable/?PAGE=cset&REV=57d78deeyfknMUHpF4CWmP8gRRf6qg
Upstream:http://bk1.ntp.org/ntp-stable/?PAGE=cset&REV=57ef749cgdfwOxXsUdn3G64d0KIoUQ
Upstream:http://bk1.ntp.org/ntp-stable/?PAGE=cset&REV=58662b53ZwV8BJejPYblqOussZZZ_w
More Information

Updated: 2017-07-05 19:14:35 UTC (commit 12857)