CVE-2016-7418

Priority
Description
The php_wddx_push_element function in ext/wddx/wddx.c in PHP before 5.6.26
and 7.x before 7.0.11 allows remote attackers to cause a denial of service
(invalid pointer access and out-of-bounds read) or possibly have
unspecified other impact via an incorrect boolean element in a wddxPacket
XML document, leading to mishandling in a wddx_deserialize call.
Assigned-to
mdeslaur
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.6.26)
Ubuntu 14.04 LTS (Trusty Tahr):released (5.5.9+dfsg-1ubuntu4.20)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=c4cca4c20e75359c9a13a1f9a36cb7b4e9601d29
Package
Upstream:released (7.0.11)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (7.0.8-0ubuntu0.16.04.3)
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=9528ce73156e2b6a5e96e371068b24a5975f4bcd
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=c4cca4c20e75359c9a13a1f9a36cb7b4e9601d29
More Information

Updated: 2018-10-31 21:24:25 UTC (commit cfa7cf69d76449ccff972ac22f40976a08d908c2)