CVE-2016-7170 (retired)

Priority
Description
The vmsvga_fifo_run function in hw/display/vmware_vga.c in QEMU (aka Quick
Emulator) allows local guest OS administrators to cause a denial of service
(out-of-bounds write and QEMU process crash) via vectors related to
cursor.mask[] and cursor.image[] array sizes when processing a
DEFINE_CURSOR svga command.
Notes
 tyhicks> vmsvga_fifo_run() in 12.04's qemu-kvm is slightly different but
  still looks to be affected
Package
Source: qemu (LP Ubuntu Debian)
Upstream:needed
Ubuntu 14.04 LTS (Trusty Tahr):released (2.0.0+dfsg-2ubuntu1.30)
Ubuntu 16.04 LTS (Xenial Xerus):released (1:2.5+dfsg-5ubuntu10.6)
Patches:
Upstream:http://git.qemu.org/?p=qemu.git;a=commit;h=167d97a3def77ee2dbf6e908b0ecbfe2103977db
Package
Upstream:needed
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
More Information

Updated: 2019-03-26 12:22:44 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)