CVE-2016-7141

Priority
Description
curl and libcurl before 7.50.2, when built with NSS and the libnsspem.so
library is available at runtime, allow remote attackers to hijack the
authentication of a TLS connection by leveraging reuse of a previously
loaded client certificate from file for a connection for which no
certificate has been set, a different vulnerability than CVE-2016-5420.
Notes
 tyhicks> only affects libcurl3-nss which is not widely used libcurl3 (OpenSSL
  based)
Assigned-to
mdeslaur
Package
Source: curl (LP Ubuntu Debian)
Upstream:released (7.50.2)
Ubuntu 12.04 ESM (Precise Pangolin):released (7.22.0-3ubuntu4.17)
Ubuntu 14.04 LTS (Trusty Tahr):released (7.35.0-1ubuntu2.10)
Ubuntu 16.04 LTS (Xenial Xerus):released (7.47.0-1ubuntu2.2)
Patches:
Upstream:https://curl.haxx.se/CVE-2016-7141.patch
More Information

Updated: 2018-10-31 21:24:23 UTC (commit cfa7cf69d76449ccff972ac22f40976a08d908c2)