CVE-2016-7132

Priority
Description
ext/wddx/wddx.c in PHP before 5.6.25 and 7.x before 7.0.10 allows remote
attackers to cause a denial of service (NULL pointer dereference and
application crash) or possibly have unspecified other impact via an invalid
wddxPacket XML document that is mishandled in a wddx_deserialize call, as
demonstrated by a stray element inside a boolean element, leading to
incorrect pop processing.
Notes
 mdeslaur> same commits as CVE-2016-7131
Assigned-to
mdeslaur
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.6.25)
Ubuntu 14.04 LTS (Trusty Tahr):released (5.5.9+dfsg-1ubuntu4.20)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:released (7.0.10-1)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (7.0.8-0ubuntu0.16.04.3)
More Information

Updated: 2019-03-19 12:27:11 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)