CVE-2016-7127

Priority
Description
The imagegammacorrect function in ext/gd/gd.c in PHP before 5.6.25 and 7.x
before 7.0.10 does not properly validate gamma values, which allows remote
attackers to cause a denial of service (out-of-bounds write) or possibly
have unspecified other impact by providing different signs for the second
and third arguments.
Notes
 tyhicks> The flaw is in the PHP code sitting in front of libgd2 and
  libgd2 does not have a part in this particular operation.
Assigned-to
mdeslaur
Package
Upstream:not-affected
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (code not present)
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.6.25)
Ubuntu 14.04 LTS (Trusty Tahr):released (5.5.9+dfsg-1ubuntu4.20)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=1bd103df00f49cf4d4ade2cfe3f456ac058a4eae
Package
Upstream:released (7.0.10-1)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (7.0.8-0ubuntu0.16.04.3)
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=e70069a62fb7252252cad9506fac5baf4ac11d21
More Information

Updated: 2018-10-31 21:24:22 UTC (commit cfa7cf69d76449ccff972ac22f40976a08d908c2)