CVE-2016-6906

Priority
Low
Description
The read_image_tga function in gd_tga.c in the GD Graphics Library (aka
libgd) before 2.2.4 allows remote attackers to cause a denial of service
(out-of-bounds read) via a crafted TGA file, related to the decompression
buffer.
References
Notes
 mdeslaur> php uses the system libgd2
Assigned-to
mdeslaur
Package
Upstream:released (2.2.4-1)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.1.0-3ubuntu0.6)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (2.1.1-4ubuntu0.16.04.6)
Ubuntu 17.04 (Zesty Zapus):not-affected (2.2.4-2)
Patches:
Upstream:https://github.com/libgd/libgd/commit/fb0e0cce0b9f25389ab56604c3547351617e1415
Upstream:https://github.com/libgd/libgd/commit/58b6dde319c301b0eae27d12e2a659e067d80558
Package
Source: php5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (uses system gd)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system gd)
Ubuntu 17.04 (Zesty Zapus):not-affected (uses system gd)
More Information

Updated: 2017-08-11 23:55:13 UTC (commit 13081)