CVE-2016-6801

Priority
Description
Cross-site request forgery (CSRF) vulnerability in the CSRF content-type
check in Jackrabbit-Webdav in Apache Jackrabbit 2.4.x before 2.4.6, 2.6.x
before 2.6.6, 2.8.x before 2.8.3, 2.10.x before 2.10.4, 2.12.x before
2.12.4, and 2.13.x before 2.13.3 allows remote attackers to hijack the
authentication of unspecified victims for requests that create a resource
via an HTTP POST request with a (1) missing or (2) crafted Content-Type
header.
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released ([2.3.6-1+deb8u2build0.14.04.1])
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.12.4-1)
Ubuntu 19.04 (Disco Dingo):not-affected (2.12.4-1)
Ubuntu 19.10 (Eoan):not-affected (2.12.4-1)
Patches:
Upstream:https://github.com/apache/jackrabbit/commit/4108e9feedb188754e59dc060db8e111b427ac37 (2.10)
Upstream:https://github.com/apache/jackrabbit/commit/987168c04327fd4fbbb4fb9d13ae92d5ca888386(2.10)
More Information

Updated: 2019-08-23 07:31:21 UTC (commit 436fd4ed4cf0038ddd382cb8649607ace163dda7)