CVE-2016-6232 (retired)

Priority
Description
Directory traversal vulnerability in KArchive before 5.24, as used in KDE
Frameworks, allows remote attackers to write to arbitrary files via a ../
(dot dot slash) in a filename in an archive file, related to KNewsstuff
downloads.
Package
Upstream:released (5.24.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (5.18.0-0ubuntu1.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Ubuntu 19.10 (Eoan):not-affected
Patches:
Upstream:https://cgit.kde.org/karchive.git/commit/?id=0cb243f64eef45565741b27364cece7d5c349c37
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [4:4.8.5-0ubuntu0.5])
Ubuntu 14.04 ESM (Trusty Tahr):released (4:4.13.3-0ubuntu0.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (4:4.14.16-0ubuntu3.3)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (4:4.14.34-0ubuntu2)
Ubuntu 19.04 (Disco Dingo):not-affected (4:4.14.34-0ubuntu2)
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-09-19 15:58:51 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)