CVE-2016-6128

Priority
Description
The gdImageCropThreshold function in gd_crop.c in the GD Graphics Library
(aka libgd) before 2.2.3, as used in PHP before 7.0.9, allows remote
attackers to cause a denial of service (application crash) via an invalid
color index.
Assigned-to
mdeslaur
Notes
mdeslaurphp uses the system libgd2
introduced in 2.1.0
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):released (2.1.0-3ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.1.1-4ubuntu0.16.04.2)
Patches:
Upstream:https://github.com/libgd/libgd/compare/3fe0a7128bac5000fdcfab888bd2a75ec0c9447d...fd623025505e87bba7ec8555eeb72dae4fb0afd
Package
Source: php5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (uses system gd)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system gd)
More Information

Updated: 2019-12-05 18:45:49 UTC (commit dd38ff22974aae499eb50644b9d5a2817483cbdb)