CVE-2016-5771 (retired)

Priority
Description
spl_array.c in the SPL extension in PHP before 5.5.37 and 5.6.x before
5.6.23 improperly interacts with the unserialize implementation and garbage
collection, which allows remote attackers to execute arbitrary code or
cause a denial of service (use-after-free and application crash) via
crafted serialized data.
Notes
 sarnold> Applications should never deserialize unauthenticated data.
 mdeslaur> does not affect 7.0.x
 mdeslaur> precise needs backported fix
 mdeslaur> we will not be fixing this in Ubuntu 12.04 LTS. We recommend
 mdeslaur> validating untrusted data before unserializing.
Package
Source: php5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):released (5.5.9+dfsg-1ubuntu4.19)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=3f627e580acfdaf0595ae3b115b8bec677f203ee
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
More Information

Updated: 2019-03-26 12:22:17 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)