CVE-2016-5766 (retired)

Priority
Description
Integer overflow in the _gd2GetHeader function in gd_gd2.c in the GD
Graphics Library (aka libgd) before 2.2.3, as used in PHP before 5.5.37,
5.6.x before 5.6.23, and 7.x before 7.0.8, allows remote attackers to cause
a denial of service (heap-based buffer overflow and application crash) or
possibly have unspecified other impact via crafted chunk dimensions in an
image.
Notes
 mdeslaur> php uses the system libgd2
 sbeattie> PEAR issues should go against php-pear as of xenial
Assigned-to
mdeslaur
Package
Source: php5 (LP Ubuntu Debian)
Upstream:released (5.5.37, 5.6.23)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (uses system gd)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:released (7.0.8)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system gd)
Patches:
Upstream:http://git.php.net/?p=php-src.git;a=commit;h=7722455726bec8c53458a32851d2a87982cf0eac
More Information

Updated: 2019-03-26 12:22:16 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)