CVE-2016-5699

Priority
Description
CRLF injection vulnerability in the HTTPConnection.putheader function in
urllib2 and urllib in CPython (aka Python) before 2.7.10 and 3.x before
3.4.4 allows remote attackers to inject arbitrary HTTP headers via CRLF
sequences in a URL.
Notes
Package
Upstream:released (2.7.10~rc1-1)
Ubuntu 12.04 ESM (Precise Pangolin):released (2.7.3-0ubuntu3.9)
Ubuntu 14.04 ESM (Trusty Tahr):released (2.7.6-8ubuntu0.3)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (2.7.10~rc1-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.7.10~rc1-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (2.7.10~rc1-1)
Ubuntu 20.04 (Focal Fossa):not-affected (2.7.10~rc1-1)
Patches:
Upstream:https://hg.python.org/cpython/rev/1c45047c5102
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [3.2.3-0ubuntu3.8])
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Ubuntu 20.04 (Focal Fossa):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (3.4.3-1ubuntu1~14.04.5)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Ubuntu 20.04 (Focal Fossa):DNE
Patches:
Upstream:https://hg.python.org/cpython/rev/bf3e1c9b80e9
Package
Upstream:released (3.5.0 alpha3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (3.5.0-1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.10 (Eoan Ermine):DNE
Ubuntu 20.04 (Focal Fossa):DNE
More Information

Updated: 2020-04-24 03:32:06 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)