CVE-2016-5424

Priority
Description
PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x
before 9.4.9, and 9.5.x before 9.5.4 might allow remote authenticated users
with the CREATEDB or CREATEROLE role to gain superuser privileges via a (1)
" (double quote), (2) \ (backslash), (3) carriage return, or (4) newline
character in a (a) database or (b) role name that is mishandled during an
administrative operation.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:released (9.1.23)
Ubuntu 12.04 ESM (Precise Pangolin):released (9.1.23-0ubuntu0.12.04)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [9.1.23-0ubuntu0.14.04])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:released (9.3.14)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (9.3.14-0ubuntu0.14.04)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:released (9.5.4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.5.4-0ubuntu0.16.04)
Patches:
Upstream:https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=fcd15f13581f6d75c63d213220d5a94889206c1b
More Information

Updated: 2020-09-10 05:29:55 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)