CVE-2016-5423

Priority
Description
PostgreSQL before 9.1.23, 9.2.x before 9.2.18, 9.3.x before 9.3.14, 9.4.x
before 9.4.9, and 9.5.x before 9.5.4 allow remote authenticated users to
cause a denial of service (NULL pointer dereference and server crash),
obtain sensitive memory information, or possibly execute arbitrary code via
(1) a CASE expression within the test value subexpression of another CASE
or (2) inlining of an SQL function that implements the equality operator
used for a CASE expression involving values of different types.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:released (9.1.23)
Ubuntu 12.04 ESM (Precise Pangolin):released (9.1.23-0ubuntu0.12.04)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was released [9.1.23-0ubuntu0.14.04])
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:released (9.3.14)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):released (9.3.14-0ubuntu0.14.04)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:released (9.5.4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (9.5.4-0ubuntu0.16.04)
Patches:
Upstream:https://git.postgresql.org/gitweb/?p=postgresql.git;a=commitdiff;h=f0c7b789ab12fbc8248b671c7882dd96ac932ef4
More Information

Updated: 2020-09-10 05:29:55 UTC (commit 81a23a978c4436cd99e1d040e9e73e9146876281)