CVE-2016-5116

Priority
Description
gd_xbm.c in the GD Graphics Library (aka libgd) before 2.2.0, as used in
certain custom PHP 5.5.x configurations, allows context-dependent attackers
to obtain sensitive information from process memory or cause a denial of
service (stack-based buffer under-read and application crash) via a long
name.
Assigned-to
mdeslaur
Notes
mdeslaurphp uses the system libgd2
Package
Upstream:released (2.2.1-1)
Ubuntu 14.04 ESM (Trusty Tahr):released (2.1.0-3ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.1.1-4ubuntu0.16.04.2)
Patches:
Upstream:https://github.com/libgd/libgd/commit/4dc1a2d7931017d3625f2d7cff70a17ce58b53b4
Package
Source: php5 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (uses system gd)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Upstream:needs-triage
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system gd)
More Information

Updated: 2020-03-18 22:45:12 UTC (commit 2ea7df7bd1e69e1e489978d2724a936eb3faa1b8)