CVE-2016-5038 (retired)

Priority
Description
The dwarf_get_macro_startend_file function in dwarf_macro5.c in libdwarf
before 20160923 allows remote attackers to cause a denial of service
(out-of-bounds read) via a crafted string offset for .debug_str.
Notes
Package
Upstream:released (20160507+git20160523.9086738-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):released (20120410-2+deb7u2build0.16.04.1)
Patches:
Upstream:https://sourceforge.net/p/libdwarf/code/ci/82d8e007851805af0dcaaff41f49a2d48473334b/
More Information

Updated: 2019-10-09 07:56:39 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)