CVE-2016-5017

Priority
Description
Buffer overflow in the C cli shell in Apache Zookeeper before 3.4.9 and
3.5.x before 3.5.3, when using the "cmd:" batch mode syntax, allows
attackers to have unspecified impact via a long command string.
Ubuntu-Description
It was discovered that Apache ZooKeeper incorrectly handled certain inputs. An
attacker could possibly use this issue to cause unspecified impact.
Notes
Package
Upstream:released (3.4.9-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 19.10 (Eoan Ermine):not-affected
Ubuntu 20.04 (Focal Fossa):not-affected
Patches:
Upstream:https://git-wip-us.apache.org/repos/asf?p=zookeeper.git;a=commitdiff;h=27ecf981a15554dc8e64a28630af7a5c9e2bdf4f
More Information

Updated: 2020-04-24 03:31:04 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)