CVE-2016-5009

Priority
Description
The handle_command function in mon/Monitor.cc in Ceph allows remote
authenticated users to cause a denial of service (segmentation fault and
ceph monitor crash) via an (1) empty or (2) crafted prefix.
Package
Source: ceph (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Trusty/esm:released (0.80.11-0ubuntu1.14.04.3)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (10.2.7-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (12.2.0-0ubuntu1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (12.2.0-0ubuntu1)
Ubuntu 19.04 (Disco Dingo):not-affected (12.2.0-0ubuntu1)
Ubuntu 19.10 (Eoan):not-affected (12.2.0-0ubuntu1)
Patches:
Upstream:https://github.com/ceph/ceph/commit/957ece7e95d8f8746191fd9629622d4457d690d6
Upstream:https://github.com/ceph/ceph/pull/9700
More Information

Updated: 2019-04-26 14:17:10 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)