CVE-2016-4972

Priority
Description
OpenStack Murano before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka),
Murano-dashboard before 1.0.3 (liberty) and 2.x before 2.0.1 (mitaka), and
python-muranoclient before 0.7.3 (liberty) and 0.8.x before 0.8.5 (mitaka)
improperly use loaders inherited from yaml.Loader when parsing MuranoPL and
UI files, which allows remote attackers to create arbitrary Python objects
and execute arbitrary code via crafted extended YAML tags in UI definitions
in packages.
Notes
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:3.0.0~b1-2)
Ubuntu 19.04 (Disco Dingo):not-affected (1:3.0.0~b1-2)
Ubuntu 19.10 (Eoan):not-affected (1:3.0.0~b1-2)
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (1:2.0.0-5)
Ubuntu 19.04 (Disco Dingo):not-affected (1:2.0.0-5)
Ubuntu 19.10 (Eoan):not-affected (1:2.0.0-5)
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.8.4-1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.8.4-1)
Ubuntu 19.10 (Eoan):not-affected (0.8.4-1)
More Information

Updated: 2019-10-09 06:22:00 UTC (commit 33aea848a182c0afcd0a3f927a01a7ecd9a061ee)