CVE-2016-4463

Priority
Description
Stack-based buffer overflow in Apache Xerces-C++ before 3.1.4 allows
context-dependent attackers to cause a denial of service via a deeply
nested DTD.
Ubuntu-Description
It was discovered that Xerces-C XML Parser fails to successfully parse a DTD
that is too deeply nested. An unauthenticated attacker could use this
vulnerability to cause a denial of service.
Notes
Package
Upstream:released (3.1.3+debian-2.1, 3.1.1-5.1+deb8u3, 3.1.1-3+deb7u4)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):released (3.1.1-5.1+deb8u3build0.14.04.1)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.2.0+debian-2)
Ubuntu 19.10 (Eoan Ermine):not-affected (3.2.0+debian-2)
Ubuntu 20.04 (Focal Fossa):not-affected (3.2.0+debian-2)
Patches:
Upstream:http://svn.apache.org/viewvc?view=revision&revision=1747619
More Information

Updated: 2020-04-24 03:30:50 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)