CVE-2016-4441

Priority
Medium
Description
The get_cmd function in hw/scsi/esp.c in the 53C9X Fast SCSI Controller
(FSC) support in QEMU does not properly check DMA length, which allows
local guest OS administrators to cause a denial of service (out-of-bounds
write and QEMU process crash) via unspecified vectors, involving an SCSI
command.
References
Bugs
Notes
 mdeslaur> qemu-kvm in precise doesn't build esp.c on Ubuntu
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Package
Source: qemu (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 14.04 LTS (Trusty Tahr):released (2.0.0+dfsg-2ubuntu1.26)
Ubuntu 16.04 LTS (Xenial Xerus):released (1:2.5+dfsg-5ubuntu10.3)
Patches:
Upstream:http://git.qemu.org/?p=qemu.git;a=commit;h=6c1fef6b59563cc415f21e03f81539ed4b33ad90
More Information

Updated: 2018-06-26 04:59:53 UTC (commit 7799c934cca373482531a7b00e4dfe82302ceae5)