CVE-2016-3956

Priority
Description
The CLI in npm before 2.15.1 and 3.x before 3.8.3, as used in Node.js 0.10
before 0.10.44, 0.12 before 0.12.13, 4 before 4.4.2, and 5 before 5.10.0,
includes bearer tokens with arbitrary requests, which allows remote HTTP
servers to obtain sensitive information by reading Authorization headers.
Ubuntu-Description
It was discovered that the npm command-line interface mishandled certain
sensitive information. An attacker could use this vulnerability to collect
authentication information that could be used to impersonate other users.
Notes
Package
Source: npm (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 ESM (Trusty Tahr):not-affected (code not present)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):needed
Ubuntu 19.10 (Eoan Ermine):not-affected (3.8.3)
Ubuntu 20.04 (Focal Fossa):not-affected (3.8.3)
Patches:
Upstream:https://github.com/npm/npm/commit/fea8cc92cee02c720b58f95f14d315507ccad401
Upstream:https://github.com/npm/npm/commit/f67ecad59e99a03e5aad8e93cd1a086ae087cb29
More Information

Updated: 2020-04-24 03:29:53 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)