CVE-2016-3190 (retired)

Priority
Description
The fill_xrgb32_lerp_opaque_spans function in cairo-image-compositor.c in
cairo before 1.14.2 allows remote attackers to cause a denial of service
(out-of-bounds read and application crash) via a negative span length.
Notes
 tyhicks> Fixed in 1.14.2
Package
Source: cairo (LP Ubuntu Debian)
Upstream:released (1.14.2-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [code not present])
Trusty/esm:DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):not-affected
Ubuntu 18.04 LTS (Bionic Beaver):not-affected
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Ubuntu 19.10 (Eoan):not-affected
Patches:
Upstream:https://cgit.freedesktop.org/cairo/patch/src/cairo-image-compositor.c?id=5c82d91a5e15d29b1489dcb413b24ee7fdf59934
More Information

Updated: 2019-04-26 14:35:16 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)