CVE-2016-3177

Priority
Description
Multiple use-after-free and double-free vulnerabilities in gifcolor.c in
GIFLIB 5.1.2 have unspecified impact and attack vectors.
Notes
 tyhicks> Flaw is in the gifcolor utility and not in the library
Package
Upstream:released (5.1.3)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (gifcolor not in giflib-tools)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (gifcolor not in giflib-tools)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (gifcolor not in giflib-tools)
Ubuntu 19.04 (Disco Dingo):not-affected (gifcolor not in giflib-tools)
Patches:
Upstream:https://sourceforge.net/p/giflib/code/ci/728772
More Information

Updated: 2019-01-14 21:19:02 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)