CVE-2016-2327

Priority
Medium
Description
libavcodec/pngenc.c in FFmpeg before 2.8.5 uses incorrect line sizes in
certain row calculations, which allows remote attackers to cause a denial
of service (out-of-bounds array access) or possibly have unspecified other
impact via a crafted .avi file, related to the apng_encode_frame and
encode_apng functions.
References
Package
Source: libav (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was not-affected [code not present])
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (7:2.8.6-1ubuntu1)
Ubuntu 17.10 (Artful Aardvark):released (7:2.8.6-1ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):released (7:2.8.6-1ubuntu1)
Patches:
Upstream:http://git.videolan.org/?p=ffmpeg.git;a=commit;h=8f4c3e4b92212d98f5b9ca2dee13e076effe9589
Upstream:http://git.videolan.org/?p=ffmpeg.git;a=commit;h=7ec9c5ce8a753175244da971fed9f1e25aef7971
More Information

Updated: 2018-04-28 06:19:36 UTC (commit 14638)