CVE-2016-2226

Priority
Medium
Description
Integer overflow in the string_appends function in cplus-dem.c in libiberty
allows remote attackers to execute arbitrary code via a crafted executable,
which triggers a buffer overflow.
References
Bugs
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):not-affected (20161220-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (20131116-1ubuntu0.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (20160215-1ubuntu0.2)
Ubuntu 17.04 (Zesty Zapus):not-affected (20161220-1)
Patches:
Upstream:https://gcc.gnu.org/viewcvs/gcc?view=revision&revision=234829
Upstream:https://gcc.gnu.org/git/?p=gcc.git;a=commit;h=b8106f544a7fd485b6959ebd197bdd99a8884416
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):not-affected (1:3.12.0-1.1ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):released (1:3.10.1-1ubuntu3~14.5)
Ubuntu 16.04 LTS (Xenial Xerus):released (1:3.11.0-1ubuntu4.2)
Ubuntu 17.04 (Zesty Zapus):not-affected (1:3.12.0-1ubuntu1)
Package
Source: ht (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.04 (Zesty Zapus):needed
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.04 (Zesty Zapus):needed
Package
Source: gdb (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):not-affected (7.99.90.20170502-0ubuntu1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):released (7.7.1-0ubuntu5~14.04.3)
Ubuntu 16.04 LTS (Xenial Xerus):released (7.11.1-0ubuntu1~16.5)
Ubuntu 17.04 (Zesty Zapus):not-affected (7.12.50.20170314-0ubuntu1)
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needed
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.04 (Zesty Zapus):needed
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 17.04 (Zesty Zapus):needs-triage
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 17.04 (Zesty Zapus):needs-triage
Package
Source: nescc (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 17.04 (Zesty Zapus):needs-triage
Package
Source: sdcc (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 17.04 (Zesty Zapus):needs-triage
Package
Upstream:needs-triage
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.04 (Zesty Zapus):DNE
More Information

Updated: 2017-10-23 12:23:37 UTC (commit 13562)