CVE-2016-2182 (retired)

Priority
Description
The BN_bn2dec function in crypto/bn/bn_print.c in OpenSSL before 1.1.0 does
not properly validate division results, which allows remote attackers to
cause a denial of service (out-of-bounds write and application crash) or
possibly have unspecified other impact via unknown vectors.
Notes
 mdeslaur> second commit needed to prevent regression
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-08-23 09:09:44 UTC (commit 436fd4ed4cf0038ddd382cb8649607ace163dda7)