CVE-2016-2177

Priority
Description
OpenSSL through 1.0.2h incorrectly uses pointer arithmetic for heap-buffer
boundary checks, which might allow remote attackers to cause a denial of
service (integer overflow and application crash) or possibly have
unspecified other impact by leveraging unexpected malloc behavior, related
to s3_srvr.c, ssl_sess.c, and t1_lib.c.
Notes
 mdeslaur> USN-3087-1 fixed this CVE in Ubuntu 16.04 LTS. Other Ubuntu
 mdeslaur> releases will be fixed in a future USN.
Assigned-to
mdeslaur
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 LTS (Trusty Tahr):needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2018-10-31 20:22:02 UTC (commit cfa7cf69d76449ccff972ac22f40976a08d908c2)