CVE-2016-2106 (retired)

Priority
Description
Integer overflow in the EVP_EncryptUpdate function in crypto/evp/evp_enc.c
in OpenSSL before 1.0.1t and 1.0.2 before 1.0.2h allows remote attackers to
cause a denial of service (heap memory corruption) via a large amount of
data.
Assigned-to
mdeslaur
Package
Upstream:released (1.0.1t, 1.0.2h)
Ubuntu 12.04 ESM (Precise Pangolin):released (1.0.1-4ubuntu5.36)
Trusty/esm:released (1.0.1f-1ubuntu2.19)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.0.2g-1ubuntu4.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (1.0.2g-1ubuntu5)
Ubuntu 18.10 (Cosmic Cuttlefish):released (1.0.2g-1ubuntu5)
Ubuntu 19.04 (Disco Dingo):released (1.0.2g-1ubuntu5)
Ubuntu 19.10 (Eoan):released (1.0.2g-1ubuntu5)
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Trusty/esm:DNE (trusty was needs-triage)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
More Information

Updated: 2019-04-26 14:35:09 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)