CVE-2016-2090

Priority
Description
Off-by-one vulnerability in the fgetwln function in libbsd before 0.8.2
allows attackers to have unspecified impact via unknown vectors, which
trigger a heap-based buffer overflow.
Notes
 mdeslaur> archive search doesn't seem to locate fgetwln usage
Package
Upstream:released (0.8.2-1)
Ubuntu 12.04 ESM (Precise Pangolin):not-affected (code not present)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (0.8.2-1)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (0.8.2-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (0.8.2-1)
Ubuntu 19.04 (Disco Dingo):not-affected (0.8.2-1)
Patches:
Upstream:http://cgit.freedesktop.org/libbsd/commit/?id=c8f0723d2b4520bdd6b9eb7c3e7976de726d7ff7
More Information

Updated: 2019-01-14 21:18:42 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)