CVE-2016-2049

Priority
Medium
Description
examples/consumer/common.php in JanRain PHP OpenID library (aka php-openid)
improperly checks the openid.realm parameter against the SERVER_NAME
element in the SERVER superglobal array, which might allow remote attackers
to hijack the authentication of arbitrary users via vectors involving a
crafted HTTP Host header.
References
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.10 (Artful Aardvark):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
More Information

Updated: 2018-04-28 06:19:27 UTC (commit 14638)