CVE-2016-1679 (retired)

Priority
Description
The ToV8Value function in content/child/v8_value_converter_impl.cc in the
V8 bindings in Google Chrome before 51.0.2704.63 does not properly restrict
use of getters and setters, which allows remote attackers to cause a denial
of service (use-after-free) or possibly have unspecified other impact via
crafted JavaScript code.
Notes
 mikesalvatore> The Ubuntu Security Team does not support libv8
Package
Upstream:released (51.0.2704.63-1)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored)
Ubuntu 14.04 LTS (Trusty Tahr):released (51.0.2704.79-0ubuntu0.14.04.1.1121)
Ubuntu 16.04 LTS (Xenial Xerus):released (51.0.2704.79-0ubuntu0.16.04.1.1242)
Ubuntu 18.04 LTS (Bionic Beaver):released (51.0.2704.79-0ubuntu2~cm1)
Ubuntu 18.10 (Cosmic Cuttlefish):released (51.0.2704.79-0ubuntu2~cm1)
Ubuntu 19.04 (Disco Dingo):released (51.0.2704.79-0ubuntu2~cm1)
Package
Source: libv8 (LP Ubuntu Debian)
Priority: Medium
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):ignored (libv8 not supported)
Ubuntu 16.04 LTS (Xenial Xerus):ignored (libv8 not supported)
Ubuntu 18.04 LTS (Bionic Beaver):ignored (libv8 not supported)
Ubuntu 18.10 (Cosmic Cuttlefish):ignored (libv8 not supported)
Ubuntu 19.04 (Disco Dingo):ignored (libv8 not supported)
Package
Upstream:released (1.15.7)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (1.15.7-0ubuntu0.14.04.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.15.7-0ubuntu0.16.04.1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-03-26 12:18:55 UTC (commit ccdecfcf0fead22bd291e5f4ea745a46872dcb15)