CVE-2016-1612

Priority
Description
The LoadIC::UpdateCaches function in ic/ic.cc in Google V8, as used in
Google Chrome before 48.0.2564.82, does not ensure receiver compatibility
before performing a cast of an unspecified variable, which allows remote
attackers to cause a denial of service or possibly have unknown other
impact via crafted JavaScript code.
Notes
 mikesalvatore> The Ubuntu Security Team does not support libv8
Package
Upstream:released (48.0.2564.82)
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was ignored)
Ubuntu 14.04 LTS (Trusty Tahr):released (48.0.2564.82-0ubuntu0.14.04.1.1108)
Ubuntu 16.04 LTS (Xenial Xerus):released (48.0.2564.82-0ubuntu1.1222)
Ubuntu 18.04 LTS (Bionic Beaver):released (48.0.2564.82-0ubuntu1.1222)
Ubuntu 18.10 (Cosmic Cuttlefish):released (48.0.2564.82-0ubuntu1.1222)
Ubuntu 19.04 (Disco Dingo):released (48.0.2564.82-0ubuntu1.1222)
Package
Source: libv8 (LP Ubuntu Debian)
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needs-triage)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):ignored (libv8 not supported)
Ubuntu 16.04 LTS (Xenial Xerus):ignored (libv8 not supported)
Ubuntu 18.04 LTS (Bionic Beaver):ignored (libv8 not supported)
Ubuntu 18.10 (Cosmic Cuttlefish):ignored (libv8 not supported)
Ubuntu 19.04 (Disco Dingo):ignored (libv8 not supported)
Package
Upstream:released (1.12.5)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (1.12.5-0ubuntu0.14.04.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (1.12.5-0ubuntu1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
More Information

Updated: 2019-03-19 12:25:12 UTC (commit 15472795df7e9de45b82f2d36b8b419b939f97b2)