CVE-2016-1251

Priority
Low
Description
There is a vulnerability of type use-after-free affecting DBD::mysql (aka
DBD-mysql or the Database Interface (DBI) MySQL driver for Perl) 3.x and
4.x before 4.041 when used with mysql_server_prepare=1.
References
Notes
 mdeslaur> only an issue with mysql_server_prepare=1, which is not the
 mdeslaur> default.
Package
Upstream:released (4.041-1)
Ubuntu 17.10 (Artful Aardvark):not-affected (4.041-2build1)
Ubuntu 12.04 ESM (Precise Pangolin):needed
Ubuntu 14.04 LTS (Trusty Tahr):needed
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 17.04 (Zesty Zapus):not-affected (4.041-1)
Patches:
Upstream:https://github.com/perl5-dbi/DBD-mysql/commit/3619c170461a3107a258d1fd2d00ed4832adb1b1 (4.041)
More Information

Updated: 2017-08-18 15:14:13 UTC (commit 13137)