CVE-2016-1249

Priority
Description
The DBD::mysql module before 4.039 for Perl, when using server-side
prepared statement support, allows attackers to cause a denial of service
(out-of-bounds read) via vectors involving an unaligned number of
placeholders in WHERE condition and output fields in SELECT expression.
Package
Upstream:released (4.039-1)
Ubuntu 12.04 ESM (Precise Pangolin):needs-triage
Trusty/esm:needs-triage
Ubuntu 16.04 LTS (Xenial Xerus):needs-triage
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (4.039-1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (4.039-1)
Ubuntu 19.04 (Disco Dingo):not-affected (4.039-1)
Ubuntu 19.10 (Eoan):not-affected (4.039-1)
Patches:
Upsteam:https://github.com/perl5-dbi/DBD-mysql/commit/793b72b1a0baa5070adacaac0e12fd995a6fbabe
More Information

Updated: 2019-04-26 14:16:45 UTC (commit 30899e40836d26e1bb5f0b072d31fd87b6cf3bd4)