CVE-2016-10743 (retired)

Priority
Description
hostapd before 2.6 does not prevent use of the low-quality PRNG that is
reached by an os_random() function call.
Notes
 mdeslaur> low-quality PRNG is only used as a fallback if /dev/urandom
 mdeslaur> can't be opened
Package
Source: wpa (LP Ubuntu Debian)
Upstream:released (2:2.6-7)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (2.1-0ubuntu1.7)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.4-0ubuntu6.4)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2:2.6-15ubuntu2.1)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected
Ubuntu 19.04 (Disco Dingo):not-affected
Patches:
Upstream:https://w1.fi/cgit/hostap/commit/?id=98a516eae8260e6fd5c48ddecf8d006285da7389
More Information

Updated: 2019-04-10 18:14:56 UTC (commit 7be72a22b065033298d574941899faeb083c1d56)