CVE-2016-10539

Priority
Description
negotiator is an HTTP content negotiator for Node.js and is used by many
modules and frameworks including Express and Koa. The header for
"Accept-Language", when parsed by negotiator 0.6.0 and earlier is
vulnerable to Regular Expression Denial of Service via a specially crafted
string.
Notes
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):released (0.6.1-1)
Ubuntu 19.10 (Eoan Ermine):released (0.6.1-1)
Ubuntu 20.04 (Focal Fossa):released (0.6.1-1)
More Information

Updated: 2020-04-24 03:23:00 UTC (commit d3f8a6ed481830fb100109a132bef581fc4176fe)