CVE-2016-10516

Priority
Medium
Description
Cross-site scripting (XSS) vulnerability in the render_full function in
debug/tbtools.py in the debugger in Pallets Werkzeug before 0.11.11 (as
used in Pallets Flask and other products) allows remote attackers to inject
arbitrary web script or HTML via a field that contains an exception
message.
References
Assigned-to
leosilva
Package
Upstream:released (0.11.11)
Ubuntu 17.10 (Artful Aardvark):not-affected (0.12.2+dfsg1-2)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):released (0.9.4+dfsg-1.1ubuntu2.1)
Ubuntu 16.04 LTS (Xenial Xerus):released (0.10.4+dfsg1-1ubuntu1.1)
Ubuntu 17.04 (Zesty Zapus):not-affected (0.11.15+dfsg1-1)
Patches:
Patch:https://github.com/pallets/werkzeug/commit/1034edc7f901dd645ec6e462754111b39002bd65
More Information

Updated: 2017-10-27 15:14:15 UTC (commit 13597)