CVE-2016-10506

Priority
Description
Division-by-zero vulnerabilities in the functions opj_pi_next_cprl,
opj_pi_next_pcrl, and opj_pi_next_rpcl in pi.c in OpenJPEG before 2.2.0
allow remote attackers to cause a denial of service (application crash) via
crafted j2k files.
Ubuntu-Description
It was discovered that OpenJPEG incorrectly handled certain j2k files. A
remote attacker could possibly use this issue to cause a denial of service.
Notes
Package
Upstream:released (2.2.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (2.2.0-1)
Ubuntu 19.10 (Eoan Ermine):not-affected (2.2.0-1)
Ubuntu 20.04 (Focal Fossa):not-affected (2.2.0-1)
Patches:
Other:https://github.com/uclouvain/openjpeg/commit/d27ccf01c68a31ad62b33d2dc1ba2bb1eeaafe7b
More Information

Updated: 2020-02-07 15:14:26 UTC (commit 9bd3a841b789565e1da6c25eff3c2d0d6cf49ce0)