CVE-2016-10321 (retired)

Priority
Description
web2py before 2.14.6 does not properly check if a host is denied before
verifying passwords, allowing a remote attacker to perform brute-force
attacks.
Notes
 sarnold> I think the 'before version' annotation in the CVE description was
  incorrect.
Package
Upstream:needed
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was needed)
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was needed)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.12.3-1ubuntu0.1)
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Ubuntu 19.04 (Disco Dingo):DNE
Ubuntu 19.10 (Eoan):DNE
Patches:
Upstream:https://github.com/web2py/web2py/commit/944d8bd8f3c5cf8ae296fc03d149056c65358426
More Information

Updated: 2019-06-25 14:14:54 UTC (commit fb4c4360fd0a8fb944c65030df15e42a767b5ff2)