CVE-2016-10210

Priority
Description
libyara/lexer.l in YARA 3.5.0 allows remote attackers to cause a denial of
service (NULL pointer dereference and application crash) via a crafted rule
that is mishandled in the yy_get_next_buffer function.
Package
Source: yara (LP Ubuntu Debian)
Upstream:released (3.6.0)
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 ESM (Trusty Tahr):DNE (trusty was not-affected [code not present])
Ubuntu 16.04 LTS (Xenial Xerus):needed
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (3.5.0+dfsg-9)
Ubuntu 19.04 (Disco Dingo):not-affected (3.5.0+dfsg-9)
Ubuntu 19.10 (Eoan):not-affected (3.5.0+dfsg-9)
Patches:
Upstream:https://github.com/VirusTotal/yara/commit/3119b232c9c453c98d8fa8b6ae4e37ba18117cd4
More Information

Updated: 2019-09-19 14:24:13 UTC (commit d32ebc32606b9517c6fa7d65a15441e2a57a6de5)