CVE-2016-10165

Priority
Description
The Type_MLU_Read function in cmstypes.c in Little CMS (aka lcms2) allows
remote attackers to obtain sensitive information or cause a denial of
service via an image with a crafted ICC profile, which triggers an
out-of-bounds heap read.
Notes
 sbeattie> openjdk-7 as of 7u111-2.6.7 uses embedded copy of lcms2 (see
  http://icedtea.classpath.org/bugzilla/show_bug.cgi?id=1896)
Package
Source: lcms2 (LP Ubuntu Debian)
Upstream:released (2.8-4)
Ubuntu 12.04 ESM (Precise Pangolin):released (2.2+git20110628-2ubuntu3.3)
Ubuntu 14.04 LTS (Trusty Tahr):released (2.5-0ubuntu4.2)
Ubuntu 16.04 LTS (Xenial Xerus):released (2.6-3ubuntu2.1)
Ubuntu 18.04 LTS (Bionic Beaver):released (2.8-4)
Ubuntu 18.10 (Cosmic Cuttlefish):released (2.8-4)
Patches:
Upstream:https://github.com/mm2/Little-CMS/commit/5ca71a7bc18b6897ab21d815d15e218e204581e2
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE (precise was released [7u121-2.6.8-1ubuntu0.12.04.1])
Ubuntu 14.04 LTS (Trusty Tahr):released (7u121-2.6.8-1ubuntu0.14.04.1)
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 18.04 LTS (Bionic Beaver):DNE
Ubuntu 18.10 (Cosmic Cuttlefish):DNE
Package
Upstream:needs-triage
Ubuntu 12.04 ESM (Precise Pangolin):DNE
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu 16.04 LTS (Xenial Xerus):not-affected (uses system lcms)
Ubuntu 18.04 LTS (Bionic Beaver):not-affected (uses system lcms)
Ubuntu 18.10 (Cosmic Cuttlefish):not-affected (uses system lcms)
More Information

Updated: 2019-01-14 22:20:53 UTC (commit 51f9b73af244ba86b9321e46e526586c25a8e060)