CVE-2016-10162

Priority
Low
Description
The php_wddx_pop_element function in ext/wddx/wddx.c in PHP 7.0.x before
7.0.15 and 7.1.x before 7.1.1 allows remote attackers to cause a denial of
service (NULL pointer dereference and application crash) via an
inapplicable class name in a wddxPacket XML document, leading to
mishandling in a wddx_deserialize call.
References
Bugs
Package
Source: php5 (LP Ubuntu Debian)
Upstream:not-affected (only affects php7.0)
Ubuntu 14.04 LTS (Trusty Tahr):not-affected (only affects php7.0)
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):DNE
Ubuntu 17.04 (Zesty Zapus):DNE
Package
Upstream:released (7.0.15)
Ubuntu 14.04 LTS (Trusty Tahr):DNE
Ubuntu Core 15.04:DNE
Ubuntu 16.04 LTS (Xenial Xerus):released (7.0.15-0ubuntu0.16.04.2)
Ubuntu 17.04 (Zesty Zapus):released (7.0.15-1ubuntu2)
Patches:
Upstream:https://github.com/php/php-src/commit/8d2539fa0faf3f63e1d1e7635347c5b9e777d47b
More Information

Updated: 2017-08-11 23:54:19 UTC (commit 13081)